Back to overview
Downtime
Power outage
Oct 26, 2023 at 2:26am UTC
Resolved
Oct 26, 2023 at 4:12am UTC
Power has been restored
Affected services
Created
Oct 26, 2023 at 2:26am UTC
Power is currently out at our house. No eta yet from pacific power
Affected services