Back to overview
Downtime

Power Outgae

Feb 03 at 06:14am PST
Affected services
weeklypancake.net
janeycreations.com
tanneybird.com
PLEX Media Server

Resolved
Feb 03 at 08:50am PST

Websites back online, servers recovered

Created
Feb 03 at 06:14am PST

Power outage affected servers, will bring them back online on my break